TheSky6 and TPoint for Windows Settings

TheSky6 can open and save a variety file formats.  The follow section describes each format and how to transition your existing data to TheSkyX.

Sky Documents

·         By default, TheSkyX uses your computer’s IP address to determine your location.  TheSkyX also has a To Google Map option that can be used verify and refine your location.  If you have the GPS coordinates of your observing site, then you can enter them manually, as well as your time zone,  from the Input > Location > Custom tab (page 36).

·         TheSkyX uses the computer’s local time by default.  See “Entering the Date and Time (Date & Time Control)” on page 139 for details how to set a specific date and time.

Field of View Indicators

·         TheSky6 stores your custom field of view indicators in a text file named Field of View Indicators.txt in the folder named <My Documents>\Software Bisque\TheSky6\Field of View Indicators.

 

TheSkyX also stores FOVIs in a text file of the same name, but in the folder named <My Documents>\Software Bisque\TheSkyX Professional Edition\Field of View Indicators.  The format of TheSky6's Field of View Indicators.txt text file the same as TheSkyX.  So, you can copy TheSky6's Field of View Indicators.txt to TheSkyX’s folder to preserve your FOVIs.

Telescope Configuration

·         Telescope-configuration is a manual process.  You'll need to manually set the telescope and the telescope settings (telescope type, COM port, limit settings, etc.) from TheSkyX.

·         Use TheSky6 to park the telescope.  Then connect to the telescope from TheSkyX and, without slewing the telescope, on the Telescope window, from the Shut Down pop-up menu, configure TheSkyX’s park position by clicking the Set Park Position command (page 375).

TPoint for Windows Settings and Models

Important Note: TPoint for Windows is not compatible with TheSkyX Professional Edition.  TheSkyX Professional Edition instead now offers the integrated TPoint Add On.

 

·         In TheSky6, the TPoint for Windows model is saved as part of the Sky Document (.SKY) document.  TPoint for Windows is a separate application.  In TheSkyX, the can be purchased as an "Add On" but is an integrated component and is accessed by clicking the Telescope > TPoint Add On command at any time (there's a 90-day free trial period to use the TPoint Add On).

To transfer an existing TPoint for Windows model to TheSkyX Pro and the TPoint Add On

1.      From TheSky6, open the TPoint document by right-clicking on the TPoint icon, and then click Open.  This launches TPoint for Windows and opens the .tpt document with the model.

2.      From TPoint for Windows, click the Export command from the File menu, then enter a name for the text file that will hold your exported mapping data.  This “pointing data” can be imported into the TPoint Add On.

3.      From TheSkyX, click the TPoint Add On command from the Telescope menu.

4.      From the TPoint Add On Setup tab, select the Import command from the TPoint Add On Settings pop-up menu.

5.      Select the text file name that holds the TPoint for Windows pointing data and then click Open.

 

The TPoint Add On now has your pointing data, and you can turn on the desired terms for your model.  A recalibration will be required to restore the CH, IH and ID terms (the telescope’s “synchronization” information).  See the TPoint Add On User Guide for more information about recalibration

Comets/Asteroids/Satellites

·         The latest orbital elements and two-line elements TLEs for these objects will need to be downloaded from TheSkyX.  See page 182 for details.

Sky Databases

A folder of TheSky6 SDBs can be converted to TheSkyX-compatible Sky Database format (.SDBX) from the Advanced tab of TheSkyX’s Database Manager (page 272).

Importing Photographic Horizons

If you have created a photographic horizon for TheSky6 for Windows and want to show it in TheSkyX do the following:

 

1.      Open the tagged image format (.tif) photograph from TheSky6 for Windows in your favorite image processing software.

2.      Save the photo as a PNG (see “Tips for Creating Panorama Photos” on page 263).

3.      Copy the PNG photo to the appropriate folder and select it as the current panoramic horizon (see “Selecting the Panorama Photo” on page 263).

 

In TheSky6, the orientation of the photographic horizon relative to the local horizon is stored in a file with the extension <Horizon Name>.horizon.  If you wish to maintain this position for the same photograph in TheSkyX, do the following:

 

1.      Manually copy TheSky6’s <Horizon Name>.horizon file for the particular photo into the Horizons folder (see “Selecting the Panorama Photo” on page 263). 

 

When the panoramic horizon is selected in TheSkyX, the appropriate horizon photo options are set based on the contents of the <Horizon Name>.horizon file, so that the photo is oriented correctly.

Importing Custom Drawn Horizons

TheSkyX can display custom-drawn horizons that were created in TheSky6.  TheSky6’s custom drawn horizon data must be saved in a TheSkyX-compatible format first.

 

Here’s how:

 

1.      Launch TheSky6.

2.      Choose the Reference Lines command from the View menu.

3.      Click the Edit Local Horizon button to show the Horizon Editor window.

4.      On the Horizon Editor window, click the Copy button to copy the horizon’s azimuth and altitude positions to the Clipboard.

5.      Launch Windows Notepad.

6.      From Notepad, type the number 360 and press the Enter key. 

7.      From Notepad, choose the Paste command from the Edit menu.

8.      From Notepad, choose the Save As command from the File menu.

9.      On the Save As window, navigate to TheSkyX’s Application Support Files Folder (see page 26).

10.  In the File Name text box of the Save As window, type the name custom horizon.hrz and click the Save button.

 

When TheSkyX is launched, and Custom Horizon is selected in the Horizon Type pop-up menu on the Horizon tab of the Horizon and Atmosphere Options window (Display menu), this custom horizon exported from TheSky6 will appear.